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 Lab 0
Combinational Logic 

How to Use Xilinx ISE 9.1i Project Navigator 

Acknowledgements:  Developed by Bassam Matar, Engineering Faculty at Chandler-Gilbert Community College, Chandler, Arizona. Funded by National Science Foundation (NSF).
Lab Summary:  
This is a voluntary lab, for those of you who lack experience in the use of computers, or Xilinx ISE 9.1i. We will walk you through a small version of a lab session and produce a totally fake lab report. In the process, though, you will use all of the main steps that you will be asked to use in all later lab work.

This lab will present design entry, simulation, and prototyping with tools that are provided by Xilinx® ISE 9.1i for this purpose.  We will show how a simple design circuit of 2 inputs AND gate can be directly entered into Xilinx® ISE 9.1i for synthesis, post synthesis simulation and timing analysis. We will show the implementation of more complex designs in future labs by running them through the design flow illustrated in this lab.

Lab Goal:  The goal of this lab is to learn the use of using Xilinx® ISE 9.1i software by implementing inputs and outputs for a simple 2 inputs AND gate.
Learning Objectives

1. Create a 2 inputs AND gate project in Xilinx® ISE 9.1i using the free software ISE WebPACK.
2. Use the Xilinx® ISE 9.1i Schematic Editor to enter a graphical design in Xilinx® ISE 9.1i.

3. Compile and simulate the 2 inputs-AND design.  

Grading Criteria:  Your grade will be determined by your instructor.  
Time Required:  2-3 hours 
Lab Preparation

· Read this document completely before you start on this experiment.

· Print out the laboratory experiment procedure that follows.

Equipment and Materials

Each team of students will need the following items as specified below.  Students should work in teams of two.
	Test Equipment and Power Supplies
	Quantity

	The following items from the Xilinx: www.xilinx.com
· free software ISE WebPACK 
	1


Additional References:  
1. Xilinx ISE 9.1i Software manuals found on Xilinx web site: www.xilinx.com

Simulation Lab 0
In this lab, you will first load and license the Xilinx® ISE 9.1i using the free software ISE WebPACK.  Then you will be given some small circuits of limited functionality.
Basic Arithmetic Functions

The three basic logic gates (AND, OR, and NOT) that you studied in your class perform the basic functions of Boolean logic.  Computers need to do other operations as well.  Now, we will provide you with circuits, built using the basic Boolean gates that perform some commonly encountered operations.  These circuits even have names because they are used so frequently.

Installing Xilinx ISE 9.1i Software
Step 1: 
Register with Xilinx at www.xilinx.com.  Download ISE Webpack and ModelSim XE package.  Select download from the top menu, then on the right hand side, select ISE WebPACK™ to download.  
Step 2: 
Install ISE Webpack.  

There might be newer version of ISE since I wrote this lab.  However, there should not be a lot of changes in the instruction between 9.1i version and the newer one.  I recommend that you download the 9.1 version.
System Requirements 

· Microsoft Windows XP Professional 

· Microsoft Windows Vista Business 

Step 3:
Have Fun!
Lab Procedure: Building AND-2 Circuit
Xilinx Design process:
[image: image43.png]Step 1: Design Entry
· Two design methods: HDL (Verilog or VHDL) or schematic drawings.  

For our class, we will use schematic method.

Step 2: Design Synthesis

· Translate V, VHDL and schematic files into an industry standard format EDIF file.
Step 3: Design Implementation

· Translate Map, Place and Route.  This process will generate a configuration file (.JED) for CPLD programming.
Step 4: Xilinx Device Programming
· Download JED file into CPLD
In this portion of the lab, you will use Xilinx ISE 9.1i Software to build AND-2 circuit.  The steps involved are design entry, synthesis, implementation, and programming.  
NOTE:  At the conclusion of the lab, you will be asked to comment on why certain steps are required.  Be sure to take notes on these questions as they appear in the lab procedure.
Design Entry Instructions 

1.  Open  Xilinx ISE 9.1 edition software

a.  Select Start   

b.  All Programs   

c.  Xilinx ISE 9.1 edition

d.  Project Navigator

Or double click on the desktop icon:


[image: image1.wmf]Xilinx  ISE 9.1i.lnk


If the starting windows does not look like this
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Figure 1
2. Create a new project by selecting:

a. File from the main menu

b. New Project as shown in figure 2

[image: image44.jpg]
Figure 2

c. In the New Project window, name your project AND_2 in the project name text box.

d. In the Project Location selection box, enter the folder or directory where your project will be saved.  Use your name for Student_Name and locate the place where you want to save all your files (i.e C:\)
e. Under Top-Level Source Type, select Schematic and click Next as shown in figure 3
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Figure 3

We will design our half adder for a particular device “Spartan 3”.  We will select Spartan 3 in the Family selection box as shown in figure 3.  We will setup the rest of the entry as you can see it in below figures.  Hit the Next button to go the next menu

[image: image4.png]Fle Edt Vew Project Souce Process Window Hep
BEHI LidBBX
[EAERR T g s

No project is open

% [T isboron ouserin.. [ 2 1=




Figure 4
2. Select New Source and create a schematic source file by simply selecting Next> and later this window will allow us to add existing files.
[image: image5.png]Fie Edit View Project Souce Process Window Help

& E A

Sources x

DRPEF LidbBX e

‘Sources for: | Syrthesis/implementati v

& &ic2_sch
& ERxe957207CS48
@ [Dfhic2_top (c2.to.

LLHKP RN

Y

= New Project Wizard - Create New Source

Create a New Source

@ &) Implement Design

Creating a new source to add to the project s optonl. Only one new sourcs can be created with the New Project Wizard
‘Addtional sources can be created and addedto the project by using the "Project >New Source” command.

Esting sources can be added on the next page

i Ii
= = ttpwww i com
x e

5
(5] Corsde | @Erors | g\ Wamings | @ittt | i i Fies

fopment Board.




Figure 5
3. Review the information listed in figure 6 and make sure it matches the information in the window. 
Then click Finish to complete the process and verify the file name and type.  Click Next once again to proceed and finish.
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Figure 6
The project summary should display similar information as shown below.  
The steps above allow us to get to below figure to start designing our circuit layout.
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Figure 7
Now, you need to add a new source “Schematic” to your project.  Add schematic by selecting Project(New source.  Type, AND-2 as shown below and click finish. Make sure you select “Schematic”
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Figure 8

The window schematic is shown below.  The file name of “AND-2” appears on the top left under Sources section.
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Figure 9

In order to select the AND-2 gate, you need to select Symbols tab as shown below.
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Figure 710

Now the screen should look like.
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Figure 11

NOTE:

It will be easier to select your gates components from Xilinx sources of devices by selecting “View( LAYOUT VERTICALLY”
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Figure 12

As you can see, it is easier to select your gates.  The gates and symbols are categories in different directories.  For basic logic gates, AND, OR, NOT, XOR, etc, they are listed under Logic.
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Figure 13

4. Enter “and2” gate in the Symbol Name Filter to select the appropriate gate.  Use the left mouse button to place the and2 symbol into the schematic diagram.  Click the right mouse button to stop the insertion process.  
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Figure 14
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Use the Zoom-in and Zoom out buttons to get a view similar to below figure: [image: image15.png][) Fle Edt View Project Source Process Add Tooks Window Help
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Figure 15

Accessing Help

At any time during the tutorial, you can access online help for additional information about the ISE software and related tools.

To open Help, do either of the following:

· Press F1 to view Help for the specific tool or function that you have selected or highlighted.

· Launch the ISE Help Contents from the Help menu. It contains information about creating and maintaining your complete design flow in ISE.

[image: image17.emf]
Figure 16: ISE Help Topics
Note:


Make sure that you create a separate folder for each of your project.  This will make your designs easy to maintain.

5. Next, we need to add wires to connect the pins and gates of our schematic.  Select “Add Wires” from the shortcut menu: 
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Extend wire from both the AND gate to attach inputs A and B to them:
6. Adding an I/O Marker

An I/O marker is an input, output, or bidirectional signal. This establishes net polarity (direction of signal flow) and shows that the net is externally accessible. All primary inputs and outputs must be marked with I/O markers as follows.

a) Select Add > I/O Marker, or click the Add I/O Marker toolbar button [image: image19.png]


.

b) In the Add I/O Markers Options that appear in the Options tab, select one of the following options to control the polarity of the marker:

For input, select:

· Add an input marker 

For output, select:
· Add an output marker

Attach input pins A and B to the schematic and outputs pin OUT.  You can change the name of your input/output pins by simply clicking on the pin and hit the right key mouse to make the appropriate name change.
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Figure 17
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7. Now our schematic is complete.  To make sure your have the correct wiring, Check for errors.  From Tools, 
Select Check Schematic.
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In the status menu right under your schematic, you should get the message:
Start DRC ...

No error or warning is detected

Make sure you save your project by clicking on the save button off the shortcut menu. [image: image24.png][ Fie Edit View Project Source Process Add Tools Window Help B[]
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Simulating your circuit in Xilinx ISE
Using the Pull-down menu under “Sources for:” pull-down menu, choose Behavior Simulation.  
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8. With the initial design completed, it is time to perform a functional simulation to check the operation.  A vector waveform file needs to be created to provide the test inputs for your project.  From the main menu, select Project, then New Source.  
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Figure 18

Select Test Bench Waveform and name your waveform file as AND_Wave as shown below:

[image: image27.png]S Xilinx - ISE - C:\Student_Name\AND_2\AND_2.ise - [AND_2.5ch*]

i IPPHH M RN AN 00
FE AL V028 N0 /OABRIA VAR

x

7] Addto project

<Back

| @ schematict | [B) AnD_25cn”

DRC Check "AND_2.sch” schematic compleced: No Error found.

Verilog netlist file "AND_2.vE" generated.
Compiling verilog file "Ci/Student_Name/AND_2/AND 2.vE"

] i

<1 |
Console | @Frors | i\ Wamings | @Tetshet | g Fndin s |

start wé | T LabOHow tou




Figure 19

Associate your test bench waveform with AND-2 schematic.  
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Figure 20

Click next, and accept AND-2 as the source file.  
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Figure 21

Review your selection and click Finish, which opens the Initialize Timing window.  Click OK to proceed.

You should now see the Initialize Timing window as shown below.  The Half_Adder circuit consists of only logic gates and does not have a clock.  Therefore, in this window, you will click select Combinational (0r internal clock), click the Finish button.
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Figure 22

You should get the following screen:
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Figure 23

As you can see the input values (A and B) are in blue and the outputs (SUM and COUT) are in yellow (not shown in figure 24).  Initially all values are in zero.  However, can change the inputs values of A and B by either clicking on the various points on the individual signals to toggle their values or you can double click on A or B inputs waveform as shown below:
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Figure 24
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For Input “A”, select “Random Signal” for “Pattern Type”.  You can select any other signals if you desire.  
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Figure 25

Do the same for input “B” by double clicking on the waveform and select Pulse for “Pattern Type”.   The waveform values of A and B should look like:
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Figure 26

Make sure you save your work.

To simulate the outputs (OUTPUT) in terms of the inputs (A and B), in  the  ISE  window,  in  the  Sources  in  Project  window,  choose “AND_2.sch” and “Simulator Behavioral model” in the ISE simulator and double-click it. Also, in the “Processes” panel, the processes “Xilinx ISE Simulator” is one choice.  Expand “Xilinx ISE Simulator” as shown below:
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Figure 27

Double click “Simulate Behavioral Model”.  If the waveform still open, you will be asked if you want to close the current Half_Adder.tbw and open a new one.  Select “Yes”.
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The simulator will ask you if you want to replace outputs with expected values.  Select “Yes”.  Below is the waveform that you should get for the appropriate values of inputs A and B.  You can arrange the inputs and outputs waveform by clicking on the variable and moving it to the appropriate place.
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As expected, the results match our truth tale:
	INPUTS

	A
	B
	Output

	0
	0
	0

	0
	1
	0

	1
	0
	0

	1
	1
	1


Figure 30

Congratulation, you have succefully completed this practice lab.
PRACTICE        PRACTICE           PRACTICE          PRACTICE       ………………..

The more you practice, the more you will be proficient with the software.

Go to the next page for an exercise on what you have learned so far.

Build the following circuit (4 inputs XOR) using 2 inputs XOR gates.
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	A
	B
	C
	D
	XOR4

	0
	0
	0
	1
	1

	0
	0
	1
	0
	1

	0
	0
	1
	1
	0

	0
	1
	0
	0
	1

	0
	1
	0
	1
	0

	0
	1
	1
	0
	0

	0
	1
	1
	1
	1

	1
	0
	0
	0
	1


Finish the rest of the table…[image: image40][image: image41][image: image42]












Double click to set the values for A and then do the same for B.
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